After long and hard work, we have finally managed to restore compatibility between SRT AppGuard and Android 5.0 Lollipop. Many thanks at this point to Marvin who has created the basics for a successful monitoring on Android 5.

For all Lollipop users we release the beta version (2.3beta1), so that SRT AppGuard can be used under Lollipop again. To install the beta version the apk file should be downloaded directly on the device and be installed over the existing version of SRT AppGuard.

Download (Version 2.3beta1)